The NGW Project Bike. Water pump rebuild

This Is Strictly For The "How To" Sticky's

Moderator: Whiskerfish

Locked
6adan
Silver Member
Silver Member
Posts: 762
Joined: Thu Dec 27, 2007 9:14 am
Location: Florence,Alabama

#16

Post by 6adan »

I took an old and a new style pump apart and found the old one had a 10mm shaft and the new one had a 12mm shaft .
Dannie
79 GL1000,75 GL1000,76 GL1000 LTD,70 CB750k JDM, 79 CBX, 2000 Valkyrie CT 2008 Goldwing Roadsmith
Trike and another 76 LTD bad shape, and several more for parts.
Grinsha
Tin Member
Tin Member
Posts: 16
Joined: Tue Nov 11, 2008 3:42 pm
Location: Montana

#17

Post by Grinsha »

Rebuilt the pump on my GL1100 a few years ago. The seal was also used on an ATV. Found one online for 14 bucks. I have the part number somewhere but didint find it in a quick search. I found 10 bearings on ebay for 12 bucks (still have eight of them left) and used my hydraulic press to remove the impeller shaft. Still works fine after a couple thousand miles.

RSN
User avatar
Rat
Photo Gallery Admin
Photo Gallery Admin
Posts: 14605
Joined: Fri Oct 21, 2005 9:59 pm
My Album: https://www.ngwclub.com/gallery/v/wingmans/rat/
RIP: cookie
Location: Toronto .... Canada

Welcome

#18

Post by Rat »

Welcome Grinsha to our little 'Wingdom.

Sounds like you'll fit in nicely :P .

Gord
"I'd rather Ride than Shine"
‘14 KLR650 ... not a rat ... yet
‘84 GL1200i ‘R2B6' (Rat to Be 6, the last, adopted by twowings)
‘76 project .... R2B3 .... sold ...
Team 898, Team LTD 993 ....
My Original 'RAT' was an '82 CB900/1100F
bobby b
Cast Iron Member
Cast Iron Member
Posts: 76
Joined: Sat Jul 25, 2009 9:40 pm
Location: prescott,az

water pump bearing

#19

Post by bobby b »

when i removed my defective water pump the seal covering the back of
the water pump bearing was missing exposing the ball bearings some were
missing [ball bearings] have tried to find the missing ball bearing cover and ball bearings
have looked everywhere [tranny cover off] where in the hell could they be.
i can see the bearings going into the oil filter but the actual missing back that is a complete mystery.
as far as i can see the cover had never been off the
bike. before removing the pump the bike ran fine [minus the overheating]

a real mystery. any litebulbs here?
thx bobby

gl 1100

gl 1200
User avatar
Q
Titanium Member
Titanium Member
Posts: 380
Joined: Wed Feb 06, 2008 9:27 pm
Location: Bend, Oregon

#20

Post by Q »

Was the bearing cage still in place?

Q
QQQ
bobby b
Cast Iron Member
Cast Iron Member
Posts: 76
Joined: Sat Jul 25, 2009 9:40 pm
Location: prescott,az

bearing cage

#21

Post by bobby b »

not sure what that is. there is something pressed into the opening and there was a place for an o-ring [removed] i slipped in the new water pump and it looks like it belongs there but the pump was not bolted to the tranny cover
i have a kit [tranny] with all the o-rings there seems to be a large squashed
o-ring in the water pump opening [engine side] does that come out?
thx bobby

gl 1100

gl 1200
User avatar
Q
Titanium Member
Titanium Member
Posts: 380
Joined: Wed Feb 06, 2008 9:27 pm
Location: Bend, Oregon

#22

Post by Q »

The bearing cage is the metal or plastic piece that keeps the balls evenly spaced.

Not sure which O rings you're talking about. If you haven't already, download a copy of the shop manual and it'll show you how it goes together.

Q
QQQ
bobby b
Cast Iron Member
Cast Iron Member
Posts: 76
Joined: Sat Jul 25, 2009 9:40 pm
Location: prescott,az

water pump seal

#23

Post by bobby b »

sorry for so many dumb questions but i want to do it right. should i add a
new water pump seal? where do you get these and how do you remove the old the black substance around the seal seems distorted. it diden't leak
before i took out the old water pump so should i replace the seal is it
necessary and is it difficult to do.
again thanks again for you help.
thx bobby

gl 1100

gl 1200
Locked

Return to “Octane's Corner”